On Friday, 14 April, the Shadow Brokers, a known hacker group, released hacking tools stolen from the United States’ National Security Agency (NSA).

These tools were designed by the NSA for their Equation Group, and are highly classified software built to be used on the systems of a wide range of major organisations, businesses, and governments.

You can read more about these tools on The Register’s article “Leaked NSA point-and-pwn hack tools menace Win2k to Windows 8”.

With the release of these tools, anyone with a small amount of knowledge can exploit Windows machines, from Windows 2000 to Windows 8, as well as Server 2003 to Server 2012 R2.

Microsoft has released a series of updates over the past few months that block these tools for working. You can see the full list of exploits and the patches that stop them on Microsoft TechNet’s article “Protecting customers and evaluating risk”.

Because of these exploits, we urgently ask that all owners of Windows VPS and dedicated servers update and install the April Security Rollup and reboot their servers to install the updates fully.

We also ask that you turn on auto-update to ensure that all Windows security patches are properly installed on your machine.

If you are on our shared hosting platform, including our Reseller platform, we have already patched and updated our shared hosting servers.

If you have further questions, or have noticed a problem with your server, please raise a ticket with our Customer Services team.

Thank you.

Was this article useful? Let others know

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...

Comments

Please remember that all comments are moderated and any links you paste in your comment will remain as plain text. If your comment looks like spam it will be deleted. We're looking forward to answering your questions and hearing your comments and opinions!

Leave a reply

Comments are closed.

Drop us a line 0330 660 0255 or email sales@heartinternet.uk